Discussion:
[notepad-plus - Open Discussion] Notepad++ v5.4.4 released
(too old to reply)
SourceForge.net
2009-07-05 16:15:03 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481099
By: donho

In the 5.4.4 version, there're a lot of bug fixes from previous versions.
The most important thing is upgrading Scintilla to the current version, that
will give Notepad++ more extended capacities in the future releases.

Please check the new release here :
https://sourceforge.net/projects/notepad-plus/files/


Notepad++ v5.4.4 fixed bugs (from v5.4.3) :

1. Upgrade Scintilla from 1.77 to 1.78.
2. Fix XML syntax highlighting bug while presence of the tag "<script/>" (Yes,
finally).
3. Fix Find in files/Find in all open files bug in non western languages (ie.
Russian, Chinese, Hebrew...).
4. Fix the find in files crash issue if find what field contains 0x0A or 0xD.
5. Fix Window7 SetWindowsHookEx() failed issue for the dockable windows. (by
recognizing windows7 environment)
6. Fix no tool bar bug under w2k.
7. Fix Incremental search bug while clicking on text zone after some searches.
8. Fix Matlab script making Notepad++ crash under Chinese windows issue.
9. Make NpWiki++ link available as on line help.
10. Add lines count on status bar.
11. Fix "In selection" bug in Find Replace features.
12. Fix the clickable link issue for some links (add '~' in RegExp).
13. Fix the bug that Notepad++ does not show on while it is minimized and its
file is modified from outside.
14. NppHelp.chm is updated.

Included plugins (Unicode):

1. TextFX v0.26
2. NppExec v0.3 RC1
3. Spell Checker v1.3.2
4. MIME Tools v1.5
5. FTP_synchronize v0.9.6
6. NppExport v0.2.8
7. Doc Monitor v2.2
8. NppNetNote v0.1
9. ChangeMarkers 1.2.1

Included plugins (ANSI):

1. TextFX v0.25
2. NppExec v0.3 RC1
3. Spell Checker v1.3.1
4. MIME Tools v1.5
5. FTP_synchronize v0.9.6
6. NppExport v0.2.8
7. Light Explorer v1.5
8. Doc Monitor v2.2
9. NppNetNote v0.1
10. ChangeMarkers 1.2.1

Please let us know if you find any critical bug.

Happy coding,
Don


______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-05 17:46:54 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481198
By: showmaster

Thanks for the new release, Don.
But found a little bug... if you are normally in the npp window and click on
the app-entry in the startmenu-bar then the editor window minimizes, but immediately
pops up again.
Minimizing the window using the icon on top right works normally.
Tobias

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-05 21:51:00 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481415
By: donho

Thank you for the hands up, Tobias.

I just did a quick fix, so please redownload it and try again.
Please notice me if you find any anomalies.

Don

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-05 22:06:06 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481435
By: klaviator

Thanks, Don, the minimizing bug has gone now - had the same problem like
Tobias.
btw: Great work again!! :-)

Dominik

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-05 22:45:59 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481476
By: rchl

I have downloaded zip package and inside unicode/plugins directory there are
two files named: "APIs" and "doc" which I believe should be directories with
files inside. Ansi directory does not have this problem.

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 00:20:27 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7481564
By: donho

Damn, you're right about it!
I remove both zip and 7z package, and added the new ones.

Please let me know if you find another thing.

Don

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 10:23:23 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482326
By: nnobby

I think you forgot to update npp.5.4.4.release.md5.

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 10:33:32 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482352
By: irradium

I've downloaded the new version but after upgrade the files (manually) my plugin's
shortcut don't work anymore: in the menu I see that they going back to the
default (like CTRL-ALT-SHIFT-E for the Explorer) but also if I using these shortcuts
nothing happen . I'm missing something or is it a bug ?
Thanks
Mauro

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 10:41:10 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482366
By: stenavin

I think, it is bug. I have reported about it here:
https://sourceforge.net/forum/message.php?msg_id=7481554

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 12:28:10 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482516
By: joergenr

After I updated to v5.4.4 the tool tips for the icons on the tool bar are wrong.
The tool tips for the plug-in icons show the name of the first menu item in
the plug-in menu. I tried a clean install. It didn't help.

Jørgen Rasmussen

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 14:15:58 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482726
By: orizens

i'm also having this bug with the shortcuts.

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 15:13:01 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7482837
By: sharljimhtsin

try it now

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 17:25:38 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7483096
By: deus-ex
Post by SourceForge.net
12. Fix the clickable link issue for some links (add '~' in RegExp).
Outstanding update, Don! All http:// links are displayed and working correctly
now.

However currently Notepad++ does not recognize ftp:// links. Could you please
add support for these in the next update as well, please? Also it would be great
if Notepad++ could recognize URLs starting just with a "www." (i.e. without
a leading http://) as working links, too.

Thank you for this marvelous editor, Don. Also much respect and thanks to all
involved in development providing patches and plugins.

_____________
Kind regards,
deus-ex (MODLAND co-admin: ftp://ftp.modland.com)

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-06 17:34:17 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7483116
By: deus-ex

In addition to my previous post: above:

The Sourceforge forum software modofied the "w w w ." to a "h t t p : // w w
w ." thus removing the sense of my sentence. So once again, hopefully displayed
right this time:

It would be great if Notepad++ could recognize URLs starting just with a "w
w w ." ( without leading h t t p : // ) as working links, too.

___________
Kind regards,
deus-ex (MODLAND co-admin: ftp://ftp.modland.com )

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-07 09:41:03 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7484552
By: cchris

Perhaps changing the way to identify a link to: it is a link if it has "://"
inside would solve all the https, then ftp, then gopher, then whatever protocol
issues.

Adding the extra rule that ^www\. and \swww\. also trigger a hotspot would
be a good idea.

But then, I'd ask for a context menu entry for "Toggle hotspot styling", because
of the potential for wrong behaviour that can't be corrected by simple inspection
of nearby text..

CChris

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-07 10:09:59 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7484613
By: cchris

Confirmed: using the installer for 5.4.4 dated July 5, 2009 23:53 , entries
in plugin menus do work, but corresponding keyboard shortcuts do not.

CChris

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-07 14:15:11 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7485190
By: cmillens

Doesn't run under Windows 7 even in compatability mode :( I needs me NPP!!

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-07 18:30:17 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7485709
By: valentin_voev

v5.4.4 doesn't search case insensitive anymore in cyrillic text. It's would
be great if correct it.

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-08 07:19:19 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7487123
By: xm1

All the plugin shortcuts stop working for me too (manual installation from the
7z).

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753
SourceForge.net
2009-07-11 03:12:38 UTC
Permalink
Read and respond to this message at:
https://sourceforge.net/forum/message.php?msg_id=7494211
By: erik_tilt

Format > Encode in ANSI ------stopped working. In v5.4.3 it worked like
a charm.

Normally, you could toggle encoding much like the way View > Character Encoding
works in Firefox. In Notepad++ v5.4.4 it gets stuck after one change.

I tried with fresh install on Windows XP (no plugins).

______________________________________________________________________
You are receiving this email because you elected to monitor this forum.
To stop monitoring this forum, login to SourceForge.net and visit:
https://sourceforge.net/forum/unmonitor.php?forum_id=331753

Continue reading on narkive:
Loading...